I have been trying for couple of weeks now but could not get a Collect server working on Ubuntu (this is a multi-user environment). I installed a latest Sqlite and postgresql driver but still the same. Can anyone help me with this issue.

Note: I'm using latest version of Collect server. I tried on both Tomcat 9 and 10 but still the same.

asked 29 Mar '22, 23:05

simiti's gravatar image

accept rate: 0%

edited 29 Mar '22, 23:06

Dear user,
First of all you should have contacted us early...!
Tomcat 10 for sure doesn't work with Collect because of some libraries used by Collect (e.g. Spring framework) that are still not compatible with Tomcat 10.
If you are installing Collect in a multi user environment, it would be preferable to use PostgreSQL and not SQLite as DBMS.
Do you have any errors in the log files when you start up Tomcat?
We will contact you to your private email address to better understand your problems.
Many thanks,
Open Foris Team

permanent link

answered 29 Mar '22, 23:14

Stefano%20%28OF%29's gravatar image

Stefano (OF) ♦♦
accept rate: 20%

Thanks. Which version of tomcat would you prefer best for collect deployment.

(30 Mar '22, 05:30) simiti simiti's gravatar image

Please use the latest version of Tomcat 9 (9.0.60) until we make Collect work with Tomcat 10 too. Many thanks.

(30 Mar '22, 15:07) Stefano (OF) ♦♦ Stefano%20%28OF%29's gravatar image

Some of the error message.

Caused by: javax.naming.NameNotFoundException: Name [jdbc/collectDs] is not bound in this Context. Unable to find [jdbc]. at org.apache.naming.NamingContext.lookup(NamingContext.java:824) ~[catalina.jar:8.5.77] at org.apache.naming.NamingContext.lookup(NamingContext.java:171) ~[catalina.jar:8.5.77] at org.apache.naming.SelectorContext.lookup(SelectorContext.java:161) ~[catalina.jar:8.5.77]

(30 Mar '22, 15:46) simiti simiti's gravatar image

org.springframework.web.context.ContextLoader - Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'liquibase' defined in class path resource [org/openforis/collect/application-context-core.xml]:

(30 Mar '22, 15:47) simiti simiti's gravatar image

there is a problem with the configuration of the database... have you defined the file collect.xml inside tomcat/conf/Catalina/localhost? Is the configuration correct? Do you have any other errors related to the DB?

(30 Mar '22, 15:50) Stefano (OF) ♦♦ Stefano%20%28OF%29's gravatar image

Here is my collect.xml <?xml version="1.0" encoding="UTF-8"?> <context path="/collect" reloadable="false">
<resource name="jdbc/collectDs" auth="Container" type="javax.sql.DataSource" factory="org.apache.commons.dbcp.BasicDataSourceFactory" driverclassname="org.postgresql.Driver" url="jdbc:&lt;a href=" postgresql:="" localhost:5432="" collect""="">postgresql://localhost:5432/collect" username="collect" password="collect123" initialSize="5" maxActive="20" maxIdle="5"> </resource> </context>

(30 Mar '22, 16:18) simiti simiti's gravatar image

I've gone through this link couple of times but still no luck. Just out of curiosity. what java version is preferred. I'm using version 11.

(30 Mar '22, 16:37) simiti simiti's gravatar image

The structure of your XML file seems to be broken.
The content of the file should be something like this:

<?xml version="1.0" encoding="UTF-8"?> <Context path="/collect" reloadable="false"> <Resource name="jdbc/collectDs" auth="Container" type="javax.sql.DataSource" factory="org.apache.commons.dbcp.BasicDataSourceFactory" driverClassName="org.postgresql.Driver" url="jdbc:postgresql://localhost:5432/collect" username="collect" password="REPLACE_THIS_WITH_YOUR_PASSWORD" initialSize="5" maxActive="20" maxIdle="5"> </Resource> </Context>

(30 Mar '22, 17:01) Stefano (OF) ♦♦ Stefano%20%28OF%29's gravatar image

I didn't put the entire script because the number of character is more than what is allowed in this comment box.

(30 Mar '22, 17:09) simiti simiti's gravatar image

Here is the error when try to manually start the collect from tomcat. FAIL - Application at context path [/collect] could not be started

(30 Mar '22, 17:10) simiti simiti's gravatar image

We have contacted you to your private email, please answer that email, many thanks.

(30 Mar '22, 17:15) Stefano (OF) ♦♦ Stefano%20%28OF%29's gravatar image
showing 5 of 12 show 7 more comments

Thanks. Issue now resolved by adding to tomcat/lib these files. 1. commons-pool-1.6.jar 2. commons-dbcp-1.4.jar

All good now and thanks Openforis support.

permanent link

answered 01 Apr '22, 02:05

simiti's gravatar image

accept rate: 0%

edited 02 Apr '22, 05:41

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 29 Mar '22, 23:05

question was seen: 688 times

last updated: 02 Apr '22, 05:41